Setting up Edgeryders Discourse for local development and testing

I’ve been trying to set up our Discourse fork, including OpenEthnographer, locally for testing and development of the new Graphryder plugin. I’m using this guide:

I had to skip a bunch of migrations to get it to install at all as I got an error about tables already existing. I skipped the following migrations:


I also deleted line 13 from 20200430010528_remove_avg_time_from_topics_posts.rb:

  execute "DROP VIEW badge_posts"

Discourse now runs, although with a whole lot of errors in the tests that seem to be related to ImageMagick. I’ve had problems with ImageMagick on macOS before, so I’m ignoring this for now as I won’t be messing with image uploads.

Now I’ve got a different problem. I’ve created an admin user with the terminal, but I can’t log in, as the Edgerydes Discourse is expecting authentication to happen with Edgeryders Communities.

How do I get around this? @gdpelican, @matthias, @daniel?

You can disable the “enable sso” Discourse admin setting directly in the Discourse database. After that, it will use local accounts for login again.

The easiest is to access and modify the database via Rails Console:

cd /path/to/discourse/
bundle exec rails console

Further instructions:

There, they also mention that a login via path /users/admin-login should still be possible with a local account. And then you can just disable Discourse SSO via the normal Discourse admin interface.

1 Like

That worked to log in, but unfortunately I’m not managing to create new posts, and I also can’t create new codes in the annotator. I can however create users, user groups and categories.

I’ve tried setting up vanilla Discourse, and can confirm that I don’t have the same problem then.

Did you have that problem @gdpelican?

I’d been running the official fork of Discourse with the annotator-store_gem installed on it, rather than the edgeryders fork, so I didn’t run into this particular issue. How custom is the edgeryders fork of Discourse?

Ah, right. That makes sense. So you just installed it according to these instructions?

Yep, exactly