NGI Ethnography Discussion

Hi all! Next Thursday at 19h sounds good. Looking forward to meeting you @alberto!

1 Like

Ok. Here is the link to join the Zoom meeting. I set it for 11am Thursday, Brussels time.

You will need to download a small application. Make sure you do that before the time allocated for the meeting. A guide for using Zoom (and, in general, video conferencing etiquette) is here.

Perfect! looking forward to the meeting. I will check-out around 12.00 as I have another meeting at 12.15. Cheers,

4 posts were split to a new topic: Codebook as a wiki: first iteration

Next NGI coding meeting is on Tuesday September 24, 15:00 Brussels time.

@alberto, can you make us a Zoom meeting link? (and/or let’s chat about giving me access credentials?)

Looking forward :slight_smile:

Zoom link here:

@matthias, we have reached a stage where we want to do an initial visualisation of the SSN on graphryder from the codes we’ve made so far. @nadia would find it useful as well. Let me know if there’s anything you need from us to do this! Thanks :slight_smile:

1 Like

I have everything I need to set this up for you gals (and guys) except that I’m missing some time :smiley: Give it 7-10 days and the NGI Graphryder installation should be up and running though. I’ll tell you here.

1 Like

Thank you!

@alberto and @amelia: Graphryder installation for the current NGI Forward corpus is ready: https://graphryder1.edgeryders.eu/

It seems to work. It says “Data is more than one month old.” in the settings but that must be just a bug because I just regenerated everything and it also says, literally five lines below:

VERSION Mon Oct 21 2019 16:25:51 … (based on latest timestamp)

Some tunings still to be made, so expect it to break every now and then again. But so far, ready to use. The installation for POPREBEL will follow shortly.

Hmm. Something is off.

36

Looks like the data might not have loaded correctly to the database?

Dunno. Have a look: https://edgeryders.eu:7473/browser/

Database looks fine.

I found the error. It’s trying to read content from Edgeryders.eu, but using the root URL graphryder1.edgeryders.eu instead.

15

I don’t remember this specific problem from when I was setting it up. I had a quick look at the dashboard for OpenVillage but couldn’t figure it out right now.

Thanks! So I know where to look …

I found the issue why detailed information about the elements does not work yet in graphryder1.edgeryders.eu. Fixing requires one of two things:

  • Some software development to make all of Graphryder API compatible with neo4j-driver 1.6.3, as described in the issue report. Will take me some more days to find the time for it.

  • Or @hugi might remember how he solved the from neo4j import Record import errors without updating neo4j-driver from 1.0.0 to 1.6.x.

1 Like

I’m looking at my fork now, and it looks I’m using 1.1.0. It was one of the changes in my hotfixes.

Thanks! Your hotfix with the upate to 1.1.0 was the first thing I tried, but the from neo4j import Record import errors persisted until version 1.6.0 (and then I went to 1.6.3 only to get the last bugfixes in that series of drivers).

If nothing else comes to mind, I’ll just complete the migration to neo4j-driver 1.6.3 in a few days.

Ah, I think I found the issue. I’m running Neo4j 3.0.1 while you are at 3.1.9. Something probably changed along the way.

That is a consequence of neo4j-driver 1.6.x only being compatible with Neo4j 3.1.9 and above. But right, the driver and database update must be causing this current issue. So as a simple solution for now, I might revert to Neo4j 3.0.1 with neo4j-driver 1.0.0 and try to solve the from neo4j import Record import errors in a different way than by updating. Finishing the update does not seem intimidating either … I’ll see. Thanks!

Yes, and to clarify, I am running 3.0.1 and 1.1.0 so you’ll probably want to start there. But maybe you already did.

1 Like